Windowsのアイドル時CPU使用率が30%超えてた

あるsvchost.exeが18%, IPROSetMonitor.exeが5%で常に20%以上上乗せされてた。svchostはキルしてもすぐ復活。

これはなんとかしなきゃと、1時間以上奮闘したのでここに供養。ちゃんと解決できたけど、そもそもどうしてこうなったのかはわからない。

判明したきっかけ

なんかパソコンが重い気がして、UserBenchmarkを回してみた。ここを使う理由は、同じパーツを使ってる人との相対評価ができるから。

とりあえず開いてるもの全部閉じて、ポチッとベンチ。2分そこらでCPU, GPU, SSD, HDD, RAMがテストできる。優秀!

おっっっと???????

開けてびっくり、バックグラウンド処理で33%も使ってる。いつも使ってるOpenHardwareMonitorを取り出して、DropBoxやらなにやらぜ~んぶ終了させても、30%から大して動かない。

解決への道のり

さすがに30%超えちゃうのはまずい。30%OFF!ってスーパーなら嬉しいけど、CPUの性能がそんだけ落とされたらたまったもんじゃない。

試行錯誤

PCの再起動、各タスクの再起動は試した。あと、ハードウェアの問題の可能性も考えてセーフモードで起動してみたけど、問題なし。やっぱりこの2つのプロセスを何とかする必要がある。

svchost.exeが18%, IPROSetMonitor.exeが5% 。 サービスホストはつまりは代行なので、キルしようが自動で再起動する系のサービスならいくらでも湧いてくる。

IPROをキルするとCPU使用率は下降する。でもこれIntelのLANアダプタのドライバ関連っぽいし、むやみに消したくない。とりあえず放置。

まず、CPU利用率が高い方からなんとかする。svchostのPIDからサービスを特定。これがWinmgmtと判明。これも結構重要っぽいし、無効化するわけにはいかない。

いろいろググったりして、これのリポジトリをリセット?とかしてみても解決せず。そもそもエラーメッセージとかも出てないし、違うっぽい。

真犯人を発見

いろいろ調べていた結果こんなサイトを発見。イベントビューアーで問題になってるPIDを探して、そのPIDで真犯人がわかるとのこと。

早速イベントビューアーを見ると、 大量のエラーメッセージが。なんだか近づいてる気がする。

イベントビューアーの「アプリケーションとサービスログ>Microsoft>Windows>WMI-Activity」のエラーから、原因となるPIDを特定。照らし合わせた結果、このPIDが IPROSetMonitor.exe のものと一致。いや、結局お前かよ。

とりあえず再インストール

この IPROSetMonitor.exe がなんなのか調べてみると、Intelのネットワークアダプタ用のドライバにくっついてくるユーティリティっぽい。そうなると流石にデリート!終わり!ってわけにも行かない。

ここで、WindowsがMicrosoftでIntelじゃない事に気がつく。Intelなら普通にDLしてきて再インストールすればいいのでは?

というわけで、Intelの公式サイトからドライバーをDL、再インストールする。入ってたバージョンは “18.1.59.0” 。2014年の代物らしい。

対する新しい方は “23.5.2” 。メジャーバージョンが5つも違うってすげー。

https://downloadcenter.intel.com/ja/download/25016/Intel-Network-Adapter-Driver-for-Windows-10

一応、PCのLANアダプタの型番を、動作確認済み製品のリストにあることを確認する。Intel(R) Ethernet Connection I217-V。ちゃんとあった。

んで、さっそくDLしたexeを起動すると怒られた。

2014年から更新されてないわけだし、それもそうかって感じで、 コンパネからアンインストール。この間、ネットにつながらなくなるので、先にドライバのインストーラをダウンロードしておく。

なんか脅されてるみたいで怖い
そして繋がらなくなるインターネット(当然)

再インストール。一瞬、CPUが30%とかになっててダメかと思ったけど、動いてるのが全然違うタスクで、しばらく放置してるといい感じに下がった。

解決

下のグラフを見ると、もとがどれだけ酷かったのかわかる。やってること同じなのに、CPU使用率にトータル30%近い差がある。

Before
After

今回はこれでうまくいったっぽい。もしこれで解決しなかったら、Windowsのクリーンインストールする羽目になってた。

何かおかしかったら再起動・再インストールが大事なのがよくわかった。あと疲れた。

おまけ(ベンチ結果)

CPU性能にえげつない差がありますね。それ以外のスコアもそこそこ伸びて(戻って?)ウレシイ。バックグラウンドCPUが33%→5%になってる。

Before

https://www.userbenchmark.com/UserRun/15229737

UserBenchmarks: Game 58%, Desk 31%, Work 30%
CPU: Intel Core i5-4670 – 45.9%
GPU: Nvidia GTX 1070 – 81.4%
SSD: Adata XPG SX900 256GB – 53.1%
HDD: Seagate Barracuda 7200.14 2TB – 88.1%
RAM: Nanya M2X4G64CB8HG9N-DG 2x4GB – 54.5%
MBD: Asus Z87I-PRO
Background CPU: 33%

After

https://www.userbenchmark.com/UserRun/15241382

UserBenchmarks: Game 86%, Desk 71%, Work 44%
CPU: Intel Core i5-4670 – 78%
GPU: Nvidia GTX 1070 – 95.6%
SSD: Adata XPG SX900 256GB – 78.7%
HDD: Seagate Barracuda 7200.14 2TB – 75.9%
RAM: Nanya M2X4G64CB8HG9N-DG 2x4GB – 60%
MBD: Asus Z87I-PRO
Background CPU: 5%

かず猫

インターネット初心者です。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

コメントする

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください